Photography, Retouching, and Life. 

The free-writing platform of Pratik Naik. A mix of curated content and personal writings. 

If Photoshop Isn't Working Smoothly For You Then This May Help

If Photoshop Isn't Working Smoothly For You Then This May Help

This is going to be one of those things that I hope isn't happening for you. In case it does, this is another thing you'll know to try. 

The Problem

I started having issues with my tools in Photoshop and things began to work less smoothly. It happened on both my PC and Mac over the last couple of years. It also spanned across a couple of versions and I could never figure it out, till now. 

Basically, the issue was that my healing and clone brush would hang up for a few seconds when I went back into Photoshop from another application. So if I was browsing the web and then came back into Photoshop, the brush would stop working for a few strokes. 

(But wait, keep reading, because this issue could manifest itself in other ways on your system.)

For instance, when you use the tools, you have to use alt/option to source a specific point and then start brushing over a blemish or an area you want to remove. Once I would source a point and start brushing, my brush would move but nothing was being modified on the image. You could see the cursor move, but the area that I was sourcing did not move at all, therefore nothing was healing.

Normally, the source point (which is a plus sign) moves in the same pattern as your cursor when you start healing or cloning something. It follows you and is mirrored to your movements. Mine did not, and it took a few attempts to get it unstuck. 

This was my problem and fortunately the solution was simple. I am making this post for people to try it out. Whether it's your Photoshop tools, or if anything in the program isn't operating smoothly, this may be your hail marry! 

The Solution

1) Basically go to Edit>Preferences>Performance. Next, ensure the "Use Graphics Processor" is checked, and then clicked on Advanced Settings 

2) Next, instead of using the "Advanced" mode, use "Normal" and hit OK. Then, restart your Photoshop and see how it works.

The four checkboxes you see will not be the same on your screen, it changes from computer to computer. However, I highly recommend checking "Use OpenCL/GL" whenever you possible can for performance reasons. 

The reason was pretty simple, on Advanced mode, the description states: 

This mode uses the graphics processor most intensively. It uses the same amount of memory as the Normal mode while enabling more advanced techniques to improve drawing performance. If this mode seems to perform less smoothly, try switching to Normal or Basic mode. 

There you go, it even warned me about things performing less smoothly. Duh!

I think it had to do with the graphics card drivers not playing nice with Photoshop. I noticed it happen every time I tried to update my drivers to the latest versions. So naturally I'd roll back. But a recent application forced me into the new drivers so I was lucky in getting it fixed. 

3) If this did nothing and you are still having issues, there are many basic things for you to try as well. For instance, increasing/decreasing your memory usage (I keep mine around 85%), adjusting your history states (mine stay around 15, I don't use many), Cache Tile Size (to 1024) or Cache Levels (I keep mine to about 4 or 5). You can also add a scratch disk in the next section, or also update your drivers, or roll back to the previous version of Photoshop in case all else fails. These may sound obvious, but I've seen the settings of 100's of Photoshop users and some of them were so off and they had no idea. 

I hope this helps! If not, then good luck to you. I feel your pain.

Celebrating The Official Launch Of Fine Art Actions

Celebrating The Official Launch Of Fine Art Actions

Here Are Detail Crops Of 100 Megapixel Medium Format Photographs

Here Are Detail Crops Of 100 Megapixel Medium Format Photographs